ID do artigo: 000059056 Tipo de conteúdo: Instalação e configuração Última revisão: 18/03/2022

Não é possível instalar o pacote Flask-PyMongo no Hub de software edge

BUILT IN - ARTICLE INTRO SECOND COMPONENT
Resumo

Etapas rápidas para instalar o pacote Flask-PyMongo no Edge Software Hub.

Descrição
  • Adicionado a seguinte linha ao arquivo requirements.txt
    • Flask-PyMongo==2.3.0
       
  • Reconstruiu a imagem e correu para o seguinte erro:

    ERRO: falha na ia_web_visualizer de serviço: o comando '/bin/sh -c pip3 instlal -r requirements.txt' devolveu um código não zero: 1
Resolução

A adição de um novo pacote requer uma conexão com a Internet. Se não houver conexão com a Internet, quaisquer alterações no arquivo requirements.txt serão revertidas e a imagem será compilado a partir do cache.

Para instalar um novo pacote:

  1. Estabelecer uma conexão com a Internet
  2. Certifique-se de que o proxy foi configurado no arquivo ~/.docker/config.json
  3. Adicione o nome e a versão do pacote ao arquivo requirements.txt
  4. Reconstruiu a imagem

Produtos relacionados

Este artigo aplica-se a 1 produtos

O conteúdo desta página é uma combinação de tradução humana e por computador do conteúdo original em inglês. Este conteúdo é fornecido para sua conveniência e apenas para informação geral, e não deve ser considerado completo ou exato. Se houver alguma contradição entre a versão em inglês desta página e a tradução, a versão em inglês prevalecerá e será a determinante. Exibir a versão em inglês desta página.